Jump to content

Recommended Posts

Help!!!

Only older versions of php mailer works

 


Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/PHPMailerAutoload.php on line 45

Fatal error: Uncaught phpmailerException: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php:1541 Stack trace: #0 /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php(1335): PHPMailer->smtpSend('Date: Tue, 18 M...', 'Hi! You request...') #1 /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php(1213): PHPMailer->postSend() #2 /home/vol11_6/hosticy.ml/www/htdocs/functions.php(235): PHPMailer->send() #3 /home/vol11_6/hosticy.ml/www/htdocs/process/register.php(78): send_mail(Array) #4 {main} thrown in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php on line 1541

Link to post
Share on other sites

No one is active on the old topic.

 

I am using Google SMTP

I also modified the php version and the autoload error is gone but i still get this error:
 


Fatal error: Uncaught exception 'phpmailerException' with message 'SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting' in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php:1541 Stack trace: #0 /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php(1335): PHPMailer->smtpSend('Date: Tue, 18 M...', 'Hi! You request...') #1 /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php(1213): PHPMailer->postSend() #2 /home/vol11_6/hosticy.ml/www/htdocs/functions.php(235): PHPMailer->send() #3 /home/vol11_6/hosticy.ml/www/htdocs/process/request_activate_account.php(43): send_mail(Array) #4 {main} thrown in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php on line 1541
 

 

 

 

Link to post
Share on other sites
3 hours ago, MS-DOS said:

You are using the legacy version of PHPMailer: https://github.com/PHPMailer/PHPMailer/tree/5.2-stable which is compatible up to version 7.0 of PHP according to what is indicated on the project page https://github.com/PHPMailer/PHPMailer make sure you are at version 7.0 otherwise check that the SMTP identifier is correct.

Project Burger doesnt works without the custom autoloader

 

It was removed in php mailer 6.0

Link to post
Share on other sites
  • 4 months later...
On 5/18/2021 at 9:45 AM, ItsGamingTube said:

No one is active on the old topic.

 

I am using Google SMTP

I also modified the php version and the autoload error is gone but i still get this error:
 


Fatal error: Uncaught exception 'phpmailerException' with message 'SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting' in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php:1541 Stack trace: #0 /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php(1335): PHPMailer->smtpSend('Date: Tue, 18 M...', 'Hi! You request...') #1 /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php(1213): PHPMailer->postSend() #2 /home/vol11_6/hosticy.ml/www/htdocs/functions.php(235): PHPMailer->send() #3 /home/vol11_6/hosticy.ml/www/htdocs/process/request_activate_account.php(43): send_mail(Array) #4 {main} thrown in /home/vol11_6/hosticy.ml/www/htdocs/libraries/PHPMailer-master/class.phpmailer.php on line 1541
 

 

 

 

This is more a place for their GitHub, but to fix that error you have to enable less secure apps in your Google account.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...