Jump to content

New Users Cannot Create Accounts


Recommended Posts

13 minutes ago, CrazyMAzeY said:

This is frustrating :(

when a user trys to create an account SIGNUP getting this error.

ERROR #8938749304 Your browser does not appear to be sending refer information this is a requirement

https://cmshosting.tk

please tell me why ??

If you are using cloudflare, please stop using it. Using cloudflare corrupts byets registration system.

Link to post
Share on other sites

I cannot believe in this day & age a hosting company making it impossible for there resellers to run a fully https site.

NOT A VERY GOOD ADVERT FOR NEW USERS

as most browsers now give warnings this is UNSECURE. I know it has put off most people i've spoken to.

I might come back when iFAST move into the 20th century ;)

 

Link to post
Share on other sites

order.cmshosting.tk/register2.php

Is there anyway to make order. subdomain secure

as I changed it from http to https in signup page it went through but i had to accept it once i did this it added an account.

PROBLEM no new user is going to do that as soon as they are greeted with UNSECURE add exception page :(

 

Link to post
Share on other sites

I changed the form post location in the sign up page form to use https://securesignup.net/register2.php as discussed in this thread. I also changed it to load the captcha image from the securesignup page so you don't get any errors about it not being secure due to mixed content, when I did a test order and clicked on the register button it goes through to the confirmation page but registration email does not arrive. I waited over 20 minutes and checked my spam folder but nothing there. So we are so close to having a working solution, it just needs the activation emails to arrive and then we can start to offer full HTTPS on our signup pages.

UPDATE: I tried again using a gmail email and this activation email did arrive, not sure why it didn't work with the other email address I tried as I am able to receive message successfully from other website to that address. So it does look like we now have a way of offering the signup page over HTTPS which should make it much more attractive to potential customers :)

 

Edited by ukclearance
Link to post
Share on other sites
23 hours ago, ukclearance said:

I changed the form post location in the sign up page form to use https://securesignup.net/register2.php as discussed in this thread. I also changed it to load the captcha image from the securesignup page so you don't get any errors about it not being secure due to mixed content, when I did a test order and clicked on the register button it goes through to the confirmation page but registration email does not arrive. I waited over 20 minutes and checked my spam folder but nothing there. So we are so close to having a working solution, it just needs the activation emails to arrive and then we can start to offer full HTTPS on our signup pages.

UPDATE: I tried again using a gmail email and this activation email did arrive, not sure why it didn't work with the other email address I tried as I am able to receive message successfully from other website to that address. So it does look like we now have a way of offering the signup page over HTTPS which should make it much more attractive to potential customers :)

 

Just to let people know, the SSL / HTTPS was achieved by enabling Cloudflare for my domain and setting it in the options on there. I recommend using Cloudflare if you haven't enabled it already from your MOFH account, as other than the free CA signed SSL you can get from them it also offers DDOS protection and caching meaning your bandwidth usage will be reduced and your site should load faster.

Link to post
Share on other sites
4 minutes ago, PlanetCloud said:

I got this message :

Posting Error, #923578257 (http://localhost/other-project/mofh-login/signup.php , localhost), Please contact support

	<form class="signupform" method=post action="https://securesignup.net/register2.php">
					<table>
						<tr><th>Username<td><input class="signupipt" type=text name=username size=30 value=""  maxlength="16" onkeyup="return ismaxlength(this)"><td>
						<tr><th>Password<td><input class="signupipt" type=password name=password size=30 maxlength="8" onkeyup="return ismaxlength(this)"><td>
						<tr><th>Email Address<td><input class="signupipt" type=text name=email size=30 value=""><td>
						                                 </td>

						<tr><th>Site Category<td><select  class="signupiptsl" size="1" name="website_category">
						<option>Personal</option>
						<option>Business</option>
						<option>Hobby</option>
						<option>Forum</option>
						<option>Adult</option>
						<option>Dating</option>
						<option>Software / Download</option>
						</select>
						</td>
						<tr><th>Site Language<td>
						<select  class="signupiptsl"size="1" name="website_language">
						<option>English</option>
						<option>Non-English</option>
						</select>
						</td>
<input type="hidden" name="plan_name" value="basic">
						<input type="hidden" name="id" value="<?PHP echo $id; ?>">
						<tr><th>Security Code<td><div class="captcha"><img width=200px; height=90px; src="https://securesignup.net/image.php?id=<?PHP echo $id; ?>"></div><td>
						<tr><th>Enter Security Code<td><input class="signupipt" type=text name=number size=30><td>
						<tr><th colspan=2><input type=submit class="signupbtn" value="Register" name=submit><td>
					</table>
				</form>

This is the form code I changed to make it work on my site, I am working on the live site rather than from a localhost, so i don't know if that might make a difference as perhaps the securesignup.net site checks the IP of the site posting the form to see if it is coming from their own servers?

Link to post
Share on other sites
2 minutes ago, PlanetCloud said:

Okay, but I don't have that edit button... 

That is strange why you can't edit your posts even though your status on the board says your a senior member and have made over 300 posts. The only reason i can see is that I created my account in May 2017 and you created yours in August 2017, so perhaps the board admins removed the option somewhere between those dates for new members but not for existing users. Perhaps open a support ticket and mention it to the admins and they can enable it.

5 minutes ago, PlanetCloud said:

Im currently patching my Free Login Templete :

 

Check it out!

New version will support SSL and the ability to define some URL's also added terms and condition page

 

The customer sign up and login looks very interesting, I will check it out. It is good to see people are actively improving the software as the signup and login pages provided by MOFH are very basic.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...