Jump to content

Remove ?i=1 from your Domain


Recommended Posts

Want to remove that pesky parameter from your domain? Well, now you can! With the simple help of .htaccess, you can have your pure domain back! Just follow these few steps.

  1. Connect to your Webserver via File Transfer Protocol (FTP)
  2. Go into your sites primary directory
  3. Modify, or Create the .htaccess file
  4. Use this code snippet and Save the file
RewriteEngine On
RewriteCond %{QUERY_STRING} .
RewriteRule ^([^.]*)$ /$1? [L,NE,R=301]

Vwolla! That harmless parameter is not to be seen anywhere.

Quote

Note: This method will erase all GET parameters. In case you want to install plugins or scripts, to your website, and they will not work, I recommend removing the content (Code Snippet) from your .htaccess document.

 

Link to post
Share on other sites

 

18 hours ago, PlanetCloud said:

Do you mean I cant use Wordpress with this?
And does the bot verification will still works?

1. Any script using GET parameters will disable certain features of scripts, determined by the function of the scripts. You can try using Wordpress. If there are any errors or bugs, troubleshoot the situation and remove the snippet from the .htaccess - if you believe it's the case.

2. It doesn't necessarily matter. You can easily add your own human verification. Takes at least 2-3 minutes of your time. 

Edited by xpde
Answered 2nd question
Link to post
Share on other sites
Just now, cloudHost said:

Willn't resetting it delete everyone's accounts on web host?

Well, web host accounts will not delete, but the forum's data will. As in all the users in my community will no longer have topics they've previously created. I already have everything set up for that in my documents. Text me over Discord for more information -.-

Link to post
Share on other sites

I tested it and it works perfect this and do some with my forum when marco www. he did not open my mother's forum this mistake

www.xxx.xxx uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

but that may also be something with cloudflare too without www. works perfect  ¬¬

Link to post
Share on other sites
  • 2 weeks later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...